Issue with Brightidea site access - July 17th 2018
Incident Report for Brightidea
Resolved
This incident has been resolved.
Posted Jul 17, 2018 - 11:15 EDT
Investigating
Our team is currently investigating a performance issue with Brightidea sites.
Posted Jul 17, 2018 - 10:03 EDT
This incident affected: Brightidea Service.